Updating RabbitMQ and RabbitMQ-Stomp to RabbitMQ 1.5.3

I noticed that the rabbitmq-stomp had stopped working on my servers after a reboot. The servers were using the Ubuntu debian package of rabbitmq and had been updgraded to RabbitMQ 1.5.3 and stomp had not since I was manually installing rabbitmq-stomp from the mercurial repositories (cause I could not find any ubuntu packages for rabbitmq-stomp).

If you used something similar to the install process described in my earlier Deploying RabbitMQ and Stomp on Ubuntu you can do the following:

Update RabbitMQ server

For Ubuntu

sudo apt-get update
sudo apt-get upgrade rabbitmq-server

For Macintosh Leopard

Need to update the rabbitmq-codegen and rabbitmq-server using mercurial:

cd /usr/lib/erlang/lib/rabbitmq-codegen
hg pull
hg update rabbitmq_v1_5_3
cd /usr/lib/erlang/lib/rabbitmq-server
hg pull
hg update rabbitmq_v1_5_3

For both Ubuntu and Leopard

Update RabbitMQ-Stomp
cd /usr/lib/erlang/lib/rabbitmq-stomp
hg pull
hg update rabbitmq_v1_5_3

You can see what release tags are available after th hg pull via the command:

hg tags

Make sure there isn’t already an /etc/rabbitmq/rabbitmq.conf . If there is merge /etc/default/rabbitmq into /etc/rabbitmq/rabbitmq.conf (/opt/local/etc/ instead of /etc if you are using MacPorts)

Otherwise just move it:

mv /etc/default/rabbitmq /etc/rabbitmq/rabbitmq.conf

Rebuild the rabbitmq-stomp programs

Still in /usr/lib/erlang/lib/rabbitmq-stomp

For Ubuntu

make RABBIT_SERVER_SOURCE_ROOT=../rabbitmq_server-1.5.3 all
/etc/init.d/rabbitmq-server restart

For Macintosh Leopard

make all

If you updated rabbitmq-server make sure it builds and run

cd /usr/lib/erlang/lib/rabbitmq-server
make -j run

If it starts ok you can quit and then from now on run it by issuing the command:

/opt/local/lib/erlang/lib/rabbitmq-server/scripts/rabbitmq-server -detached
Share and Enjoy:
  • Print
  • Digg
  • StumbleUpon
  • del.icio.us
  • Facebook
  • Yahoo! Buzz
  • Twitter
  • Google Bookmarks
  • LinkedIn
  • Slashdot
  • Suggest to Techmeme via Twitter

1 comment to Updating RabbitMQ and RabbitMQ-Stomp to RabbitMQ 1.5.3

Leave a Reply

  

  

  

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>